TBL XG2: The New Site Design - Errors, Issues, Oddities, Etc

Find our latest site news here. Want to contribute, have an idea or having a problem? Post your feedback here!
User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

TBL XG2: The New Site Design - Errors, Issues, Oddities, Etc

Post by archibalduk » Sun May 16, 2010 11:31 am

Please use this thread to report any issues such as:
  • Errors
  • Features not working correctly or in an unexpected manner
  • Design flaws
  • Design inconsistencies
  • Any other issues or design issues
If you wish to leave general feedback or suggestions for new features then please use the following thread instead: http://www.ehmtheblueline.com/forums/vi ... 9172#99172


When reporting an issue it would be helpful if you tell me which web browser you are using.


Known issues which I'm working on:
  • Some design issues with Internet Explorer. In particular, some elements may be a little offset (horizontal grey dividing lines in particular). This is because IE parses CSS in different way to other browsers.
  • Multi quote doesn't work on IE.
  • Some of the facepack thumbnails/previews on the Facepack Page do not have gaps/spacing between each other.
  • Background of the Blogs page should be blue rather than white. This is an apparent CSS issue which needs some investigating.
  • Drop down menu does not work in IE. A temporary myTBL nav bar is in use. I'm going to try to implement the drop down menu in IE. Again, this is a CSS issue!
  • The Downloads Database stats do not work. It looks as though they never worked on the old site either!!
  • The page for reading PMs could be a little tidier.
  • PM notification window could be a little tidier.
  • Some of the button icons could look nicer.
  • The default hockey player silhouette is displaying for users that haven't yet set a face picture for their GM Profile.

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Sun May 16, 2010 12:49 pm

A small issue noticed: When a user isn't logged in, "User Groups" appears in the nav bar which makes it wrap onto a second line. I'll fix this tonight

[FIXED]
Last edited by archibalduk on Sun May 16, 2010 5:37 pm, edited 1 time in total.

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 2:35 pm

I wouldn't call that an "issue" but when I write my post in the Thrash talk, when you write your post and it show view your message, when the page load it come back right at the top of the page instead of letting you at your post at the bottom. :dunno: Doesn't really bother me I'm just saying.

User avatar
Círyatan
Leading Scorer
Posts: 829
Joined: Fri Oct 09, 2009 12:00 am
Custom Rank: Eagle eyes!
Location: Gdańsk, Poland

Post by Círyatan » Sun May 16, 2010 3:20 pm

Just a couple of minor details. Using Safari 4.0.5 (Mac).

Image

The magnifying glass icon seems to not fit in the search field (no. 1). Also, when highlighting the search field, only a section of it seems active, instead of the whole field (no. 2; dunno if it's an issue, it would just make more sense to me to have it that way).

Also, when I click on the unread posts icon anywhere in the forums, it doesn't get me to the first unread post, but to the top of the page where the post is. Get last post buttons work similarly wrong. Might be related to what Philou wrote above. Highly annoying.

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 3:26 pm

Yup that's what I wanna explain, I was thinking that it was doing this only when you write a post but it do it to when you wanna check the new posts.

User avatar
Círyatan
Leading Scorer
Posts: 829
Joined: Fri Oct 09, 2009 12:00 am
Custom Rank: Eagle eyes!
Location: Gdańsk, Poland

Post by Círyatan » Sun May 16, 2010 3:47 pm

Círyatan wrote:The magnifying glass icon seems to not fit in the search field (no. 1). Also, when highlighting the search field, only a section of it seems active, instead of the whole field (no. 2; dunno if it's an issue, it would just make more sense to me to have it that way).
It looks even worse when I'm not logged in:

Image

User avatar
Calv
TBL Admin Team
Posts: 4424
Joined: Tue Jul 06, 2004 9:02 pm
Custom Rank: Goalie....Sieve....!
Favourite Team: Team GB
Location: Manchester, UK

Post by Calv » Sun May 16, 2010 4:17 pm

That looks to me like it could be resolution or browser specific problem, do you have another browser that you could try it on? It doesn't happen on my laptop.... :dunno:

There is a slight issue with the downloads section, there is a message at the top of my screen that I've taken a screenshot of.

Downloads CHMOD permissions issue fixed - Archi

Downloads section error:
Image

Search bar working for me in Firefox & 1280x800 screen resolution
Image

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 4:34 pm

I've got no problem with that too.

User avatar
Círyatan
Leading Scorer
Posts: 829
Joined: Fri Oct 09, 2009 12:00 am
Custom Rank: Eagle eyes!
Location: Gdańsk, Poland

Post by Círyatan » Sun May 16, 2010 4:38 pm

Checked in Firefox and Camino, same problems. My screen resolution is 1024x768. :dunno:

User avatar
B. Stinson
TBL Admin Team
Posts: 5131
Joined: Mon May 08, 2006 11:22 pm
Favourite Team: Philadelphia Flyers
Location: Telford, PA

Post by B. Stinson » Sun May 16, 2010 5:28 pm

I'm loving this design! Couple issues I've seen so far:

- [Firefox 3.6.3] Search box magnifying glass is overlapping the left end of the search box, as shown in Ciryatan's first screenshot (It's actually pushed out of the box more for me than it is in Ciryatan's screenshot).

- [Firefox 3.6.3] Nav bar corners appear to be 2 pixels too short, also shown in Ciryatan's first screenshot.

- [Firefox 3.6.3] Google Map Data copyright line too long in user profile editing (I'm guessing this is an automatic part of the map, so there's probably not much you can do about it).

- [Firefox 3.6.3] The little tiny box that takes you to "The Latest Post" doesn't appear to be working.

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Sun May 16, 2010 5:35 pm

Has anybody used the multi-quote yet? It's such a handy feature! :cool:

Círyatan - the issues about the nav menu going on to two lines with the User Groups link is something I spotted right after installing the site (see quote below). It was a mistake I'd made when making last minute changes to the code last night. I've fixed it now:
archibalduk wrote:A small issue noticed: When a user isn't logged in, "User Groups" appears in the nav bar which makes it wrap onto a second line. I'll fix this tonight.
Círyatan wrote:Checked in Firefox and Camino, same problems. My screen resolution is 1024x768. :dunno:
It's not to do with the screen resolution (the site is designed for 1024x768 and upwards) but it's to do with the CSS margin/padding/border of the search bar. Looks like it's specific to Mac browsers. I've made a slight tweak to the CSS; try refreshing the page. Is it resolved? If not, I'll have to see if I can get Safari on Ubuntu.

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 5:41 pm

archibalduk wrote:Has anybody used the multi-quote yet? It's such a handy feature! :cool:
You improve it in what way??

User avatar
B. Stinson
TBL Admin Team
Posts: 5131
Joined: Mon May 08, 2006 11:22 pm
Favourite Team: Philadelphia Flyers
Location: Telford, PA

Post by B. Stinson » Sun May 16, 2010 5:46 pm

philou21 wrote:
archibalduk wrote:Has anybody used the multi-quote yet? It's such a handy feature! :cool:
You improve it in what way??
Next to the "Quote" button there is a little + sign. You can use that to add multiple quotes to a reply.

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Sun May 16, 2010 5:47 pm

Image

Aha I've just opened it up on Firefox 3.6.3 and can see the issue with the search box. Also, something is making the nav bar 2px higher than it should be which is what's making that gap in the corners. It was working fine earlier this week so it must be something to do with the IE-only nav bar I added in the code.

Which tiny little box (re latest posts)? Would you mind posting a screenshot at all? I wonder if this is what Philou is referring to. Edit - I think I know what you mean. I believe I've fixed it now.

I'll check out the Google Maps copyright :thup:
Last edited by archibalduk on Sun May 16, 2010 5:54 pm, edited 1 time in total.

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 5:48 pm

B. Stinson wrote:
philou21 wrote:
archibalduk wrote:Has anybody used the multi-quote yet? It's such a handy feature! :cool:
You improve it in what way??
Next to the "Quote" button there is a little + sign. You can use that to add multiple quotes to a reply.
Maybe I'm blind but there's nothing next to my quote button. :dunno:

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Sun May 16, 2010 5:53 pm

philou21 wrote:
B. Stinson wrote:
philou21 wrote: You improve it in what way??
Next to the "Quote" button there is a little + sign. You can use that to add multiple quotes to a reply.
Maybe I'm blind but there's nothing next to my quote button. :dunno:
Are you using Internet Explorer? Multi-quote doesn't work in IE at the moment.

By the way, try clicking on the latest post box now. It should take you to the bottom of the thread to that post.

User avatar
Círyatan
Leading Scorer
Posts: 829
Joined: Fri Oct 09, 2009 12:00 am
Custom Rank: Eagle eyes!
Location: Gdańsk, Poland

Post by Círyatan » Sun May 16, 2010 5:56 pm

archibalduk wrote:By the way, try clicking on the latest post box now. It should take you to the bottom of the thread to that post.
It looks like it does! :banana:
archibalduk wrote:Has anybody used the multi-quote yet? It's such a handy feature! :cool:

Círyatan - the issues about the nav menu going on to two lines with the User Groups link is something I spotted right after installing the site (see quote below). It was a mistake I'd made when making last minute changes to the code last night. I've fixed it now:
archibalduk wrote:A small issue noticed: When a user isn't logged in, "User Groups" appears in the nav bar which makes it wrap onto a second line. I'll fix this tonight.
Oh, I read it but somehow didn't remember reading. Looks like it's ok now.
archibalduk wrote:
Círyatan wrote:Checked in Firefox and Camino, same problems. My screen resolution is 1024x768. :dunno:
It's not to do with the screen resolution (the site is designed for 1024x768 and upwards) but it's to do with the CSS margin/padding/border of the search bar. Looks like it's specific to Mac browsers. I've made a slight tweak to the CSS; try refreshing the page. Is it resolved? If not, I'll have to see if I can get Safari on Ubuntu.
Yes, it definitely looks better now. :thup: However, the background behind the search field and also on the far left side of the nav bar seems to be slightly different from the rest of the bar; it's visible on the screen you've posted. :dunno: And of course this height issue you've already talked about...

Anyway, keep up the good work! The new feel truly is phenomenal. :-D
Last edited by Círyatan on Sun May 16, 2010 6:03 pm, edited 1 time in total.

User avatar
philou21
The Great One
Posts: 9376
Joined: Sun Nov 23, 2008 8:15 pm
Custom Rank: 24 cups!!!
Favourite Team: Colorado Avalanche
Location: Trois-Rivières, Québec

Post by philou21 » Sun May 16, 2010 5:58 pm

Yes I'm using IE, that's why, anyway that doesn't bother me. When I clik on my msg in my e-mail box, it take me right in the bottom of the page now. :thup:

Edit: It works too when you confirm your post.

User avatar
B. Stinson
TBL Admin Team
Posts: 5131
Joined: Mon May 08, 2006 11:22 pm
Favourite Team: Philadelphia Flyers
Location: Telford, PA

Post by B. Stinson » Sun May 16, 2010 5:59 pm

Awesome work Archi! It's working!

...And you did it before I even had time to get a screenshot up. ;)

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Sun May 16, 2010 6:00 pm

B. Stinson wrote:Awesome work Archi! It's working!

...And you did it before I even had time to get a screenshot up. ;)
Haha sorry about that! :D It just suddenly clicked what you meant and what the issue would be.

Btw, congrats on 2000 posts. Maybe I should make one of the B72 badges for you! :D

User avatar
B. Stinson
TBL Admin Team
Posts: 5131
Joined: Mon May 08, 2006 11:22 pm
Favourite Team: Philadelphia Flyers
Location: Telford, PA

Post by B. Stinson » Mon May 17, 2010 8:42 am

I've got some info for you in regards to the sizing issues of the nav bar corners:

I was on my Windows XP drive a few hours ago, and I happened to drop by here (still on Firefox 3.6.3). I also happened to take note of the nav bar, and it wasn't suffering from the size issue, nor was the magnifying glass being pushed out of the search box.

So, it appears that on Linux Firefox 3.6.3 and Mac Safari, it's a little off. But on Windows XP Firefox 3.6.3, it's OK. :-k

User avatar
McQwak
Stanley Cup Winner
Posts: 1437
Joined: Mon Nov 05, 2007 1:59 pm
Custom Rank: Now with capital letters!
Location: Prague, Czech rep.

Post by McQwak » Mon May 17, 2010 9:23 am

"Recent Winners" box in the Challenge Centre shows only winners to 11th challenge.

Edit: and GM profile pictures don't work, I guess. At least I see none (using IE 6).

User avatar
Manimal
TBL Admin Team
Posts: 6329
Joined: Thu Apr 24, 2008 4:01 am
Custom Rank: EHM Rosters Man
Favourite Team: Djurgårdens IF
Location: Karlstad, Sweden

Post by Manimal » Mon May 17, 2010 11:34 am

The EHM challenges title bar links to the wrong stat recording sheet. It should be the 6.2 version, not 6.0

User avatar
archibalduk
TBL Admin Team
Posts: 19349
Joined: Tue Jul 06, 2004 8:44 pm
Custom Rank: Seaside + Fruit Juice Mode
Favourite Team: Guildford (EPL) / Invicta (NIHL)
Location: United Kingdom
Contact:

Post by archibalduk » Mon May 17, 2010 6:58 pm

B. Stinson wrote:I've got some info for you in regards to the sizing issues of the nav bar corners:

I was on my Windows XP drive a few hours ago, and I happened to drop by here (still on Firefox 3.6.3). I also happened to take note of the nav bar, and it wasn't suffering from the size issue, nor was the magnifying glass being pushed out of the search box.

So, it appears that on Linux Firefox 3.6.3 and Mac Safari, it's a little off. But on Windows XP Firefox 3.6.3, it's OK. :-k
I found Firefox (both Windows and Linux) to be very temperamental with the header corners. I managed to resolve it but when I started adding the IE compatible version, the issue has arisen again. I'm going to re-code the nav bar from scratch so hopefully this will resolve it - and hopefully the drop down menu will work with IE.

McQwak wrote:"Recent Winners" box in the Challenge Centre shows only winners to 11th challenge.

Edit: and GM profile pictures don't work, I guess. At least I see none (using IE 6).
Recent winners - this is because we haven't seemingly awarded trophies for Challenge 12 onwards (but I assume we have awarded TBL Points). I need to clarify this Calv. I'll be posting some info about Challenges 15 and 16 hopefully this week.

Your GM Profile picture works fine on Chrome. I'm 99% sure that it works fine on IE8. I suspect that it's an issue with IE6 and CSS (I believe that IE6 isn't compatible with much CSS). Although it looks like the card template is 1px too narrow - I need to check this out.
Manimal wrote:The EHM challenges title bar links to the wrong stat recording sheet. It should be the 6.2 version, not 6.0
Thanks. I'll sort that out :thup:

User avatar
Círyatan
Leading Scorer
Posts: 829
Joined: Fri Oct 09, 2009 12:00 am
Custom Rank: Eagle eyes!
Location: Gdańsk, Poland

Post by Círyatan » Tue May 18, 2010 4:11 pm

Sorry, Archi, I don't like being the most problematic user. :oops: That's how the reply buttons look like when I'm not logged in. Safari 4.0.5 (Mac). In both Firefox and Camino it looks normal.

Image

Post Reply

Return to “TBL Announcements and Feedback”